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“Plaut04” is a graphic tool for AUTO data visualization. Here we
explain how to view AUTO data sets with Plaut04. An AUTO data set
contains a solution file, “s.foo”, a bifurcation file, “b.foo”, and a diagnostic
file, “d.foo”. Here “foo” denotes a user-chosen data set name. This user’s
guide includes the following information:

1. A description of the Plaut04 window system.

2. A list of Plaut04 configuration options.

3. An example of using Plaut04.

1 Quick start

1.1 Starting and stopping Plaut04

1.1.1 Starting

The starting command for Plaut04 is: “plaut04”. A short Unix command
is also provided as “@pl”. In the Python CLUI, one can start Plaut04 by
typing “plot3()”, “p3()”, or “commandPlotter3D()”.

This command can have no argument, one argument, or two arguments.
If no argument is provided, then the system uses the AUTO default data

files, fort.7, fort.8, and fort.9, as inputs.
If one argument is given, it must be the name of the data set which we

want to view. This data set should be in the current directory.
When two arguments are given, the first is always the path to the data

set, and the second is the data set name.
Note that the AUTO data set name does not mean the full name of an

AUTO file. It refers to the postfix of AUTO data files. For example, if we
have the AUTO data files: “s.H1”, “b.H1”, and “d.H1”, the AUTO data file
name is “H1”.

1.1.2 Stopping

One can exit the system by clicking the cross at the top-right corner of the
window or from the “File” menu of the system.
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1.2 Changing the “Type”

Often one will frequently change between the solution diagram and the bi-
furcation diagram. The “Type” menu helps to complete this change. This
menu includes two items, “Solution”, and “Bifurcation”. There is a marker
beside the current diagram. For example, if the current diagram is the solu-
tion diagram, but we want to change to the bifurcation diagram, we can do
so by clicking “Type → Bifurcation” to switch to the bifurcation diagram.

Figure 1: The Type Menu Figure 2: The Style Menu

1.3 Changing the “Style”

Plaut04 provides four ways to draw the graphics, i.e., using curves, tubes,
points, or as a surface. One can select the style from the “Style” menu. The
“Style” menu is shown in Figure 2.

1.4 Coordinate axes

Figure 3 shows the selections of the “Coord” menu. One may use this menu
to select to show or not to show coordinate axes, and the type of coordinate
axes, in the graphics.

1.5 Options

The “Options” Menu provides functions to add or remove widgets from the
graphics. It also allows to start/stop solution or orbit animation. The “nor-
malize data” normalizes the raw data to [0,1]. “Preference” lets us set pref-
erences for the GUI (see Figure 4).
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Figure 3: The Draw-Coordinate-Axes
Menu Figure 4: The Options Menu

1.6 CR3BP animation

The “Center” Menu allows to animate the motion of the three bodies in
different coordinate systems. We can animate the motion in a large-primary-
centered inertial coordinate system, or in a small-primary-centered inertial
system, or in the bary-centered inertial system. Figure 5 displays the layout
of the “Center” menu.

Figure 5: The Center Menu Figure 6: The Help Menu

1.7 Help

The “Help” menu provides an on-line help on how to use Plaut04.
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1.8 Picking a point in the diagram

The picking operation is useful when we want to know data corresponding
to a certain point in the diagram. In order to execute a picking operation,
we should follow these steps.

• Click the arrow icon to change the mouse to picking state.

• Move the mouse to the point of interest.

• Click the left button of the mouse to pick the point.

Once a point has been picked, a new window is popped up. In this new
window, the Floquet multipliers of the point are shown in an x-y plane. Black
crosses in the diagram indicate the Floquet Multipliers. The solution, and
the values of the corresponding Floquet Multipliers, are given in the lower
part of the window. A unit circle is drawn in the diagram. Figure 7 is an
example of the picking operation. From this diagram, we can see that two
Floquet Multipliers are outside the unit circle, two are on the unit circle, and
the other two are inside the unit circle.

1.9 Choosing the variables

AUTO can generate large amounts of data. The CR3BP, for example, has
6 variables, i.e., x, y, z, x′, y′, z′, and time. One can choose to draw any
combination of these variables in 2 or 3 dimensions using Plaut04. On the
list bar, we can see three dropdown lists with label “X”, “Y”, and “Z” (See
Figure 8). Each of these three lists has the exact number of choices, namely,
the number of variables of the system plus one. In our case, these lists have
7 choices, which are represented by the integers 0 to 6. 0 represents time.
1 to 6 stand for x, y, z, x′, y′, and z′, respectively. “1” is selected for “X”,
which indicates that x is drawn on the X-axis. “2” is selected for “Y”, which
indicates that y is represented on the Y-axis. “3” is selected for “Z”, which
indicates that z is represented on the Z-axis.

We can also show multiple combinations at the same time. For example,
if we want to show x-y-z and x’-y’-z’ in the same diagram, we can input 1, 4
in the “X” dropdown list to select x and x′ being drawn on the X-axis, input
2, 5 in the “Y” list to show y and y′ on the Y-axis, and input 3, 6 in the “Z”
dropdown list to draw z and z′ on the Z-Axis. Note that after finishing the
input in the dropdown list box, we must type “ENTER” for the input to be
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Figure 7: Picking a point

accepted by the system. Figure 9 shows the results of the above choices. The
combination is flexible. For example, if X is 1, Y is 3, 5, and Z is 4, 5, 6, the
system will automatically reorganize them to 1− 3− 4, 1− 5− 5, 1− 3− 6
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Figure 8: Menu-bar layout

and show the results. If X is 1, 5, Y is 2, and Z is 3, 4, the system reorganizes
them to 1− 2− 3, 5− 2− 4.
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Figure 9: Displaying multiple components

Different components are drawn with different colors from blue to red.
The default values can be set in the resource file. If no resource file exists,

then the system will use “1” for X-axis, “2” for Y-axis, and “3”for Z-axis for
both the solution and the bifurcation diagrams.

1.10 Choosing labels

From the Label list, we can choose the label of the solution to be drawn.
If “ALL” is chosen, all solutions are shown in the diagram. If “NONE” is
chosen, none of the solutions is shown. “HALF” shows the solutions with odd
labels and special solutions only. “SPEC” lets the system show the special
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solutions only. We can also show selected solutions by inputting their labels
in the list box separated by commas. For example, typing 1, 10, 15, 20 will
lead the system to show only the solutions with label 1, 10, 15 and 20.

We can set the default value for this list in the Plaut04 resource file.

1.11 Coloring

Many coloring methods are provided. They can be classified into three
groups. The first group is coloring by variables. This group provides as
many choices as the number of variables of a problem plus 1 for the time.
The second group is coloring by parameters. These parameters are defined
by the AUTO user. in the AUTO constants file. There are as many choices
as the number of parameters defined in the AUTO constants file. The third
group includes “TYPE”, type of solution, “PONT”, point number, “BRAN”,
the branch to which the solution belongs, and “LABL”, label of the solution.
Different coloring methods cannot be used at the same time. Figure 10 shows
the difference between coloring by type and coloring by label. From Figure
10(a), we can see that there is only one branching orbit in this family, which
is shown in cyan. In Figure 10(b), the start solution is colored in blue, and
the last solution is colored in red. When using time to color the diagram, 0
is set to blue, while 1 is set to red.

(a) Coloring by “Type” (b) Coloring by “Label” (c) Coloring by “Time”

Figure 10: Coloring

We can set the default value in the Plaut04 resource file.
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1.12 Number of periods to be animated

Generally only one period is animated when we animate the solution in the
inertial frame. However, the SpinBox allows us to change the default value.
This is a specially designed function for the CR3BP. It is useful when we
animate the motion in the three bodies in the inertial frame.

1.13 Changing the line/tube thickness

The “Line Thickness” spinbox allows us to increase or decrease the line/tube
thickness in the diagram. The Plaut04 resource file also provides a way to
change the default values of the line/tube thickness.

1.14 Changing the animation speed

The “Sat” and “Orbit” scale bar allow us to change the animation speed.
Their Maximum and Minimum value can be set in the resource file.

1.15 Changing the background picture

A user can set the background with his favorite picture. To do this, a user
should copy the picture to the directory “$AUTO DIR/plaut04/widgets”,
and then change the name of the file to “background.rgb”.

2 Setting up the resource file

The Plaut04 resource file sets default values for almost all controls of
Plaut04. Plaut04 allows us to write our own resources files and put
them in the same directory as the AUTO data files. Plaut04 first looks
for the resource file in the current directory. If it cannot find a resource file
there, then it will try to use the one installed in the AUTO root directory.
If both these searches fail, then the internal default values will be used.

In order to write a usable resource file, one should follow the following
rules:

1. Comment lines start with “#”. Comments may take as many lines as
desired.
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2. Between the “variable name” and the default value, we must use “=”
to tell the system that the left side is the “variable name”, and the
right side is its corresponding default value.

3. If a “variable” has aggregate values, a comma “,” must be used between
two values.

4. The line type is set using 4-digit hexadecimals, starting with “0x”.
Its values can range from 0 (invisible) to “0xffff” (solid). The system
default is “0xffff” for stable solutions, and “0x3333” for unstable ones.
The line pattern is determined by the number of 1s and 0s when the
hexadecimal is converted to a 16-bit binary. A “1” indicates that the
drawing occurs, and “0” that it does not, on a pixel by pixel basis. For
example, the pattern “0xAAAA”, in binary is 0000100010001000, and
Plaut04 interprets this as drawing 3 bits off, 1 bit on, 3 bits off, 1
bit on, 3 bits off, 1 bit on and finally 4 bits off. The pattern is read
backward because the low order bits are used first.

5. Some variables can only be set to “Yes” or “No”. They cannot be
assigned other values.

6. No “variable name” should be modified.

It is strongly recommended that the default resource file is used as a
template when writing a custom resource file.

Below is a copy of the default resource file.

#version 0.0

# Line colors are represented by RGB values from 0 to 1.0.

# DEFAULT color is also used when animationLabel == 0, i.e.,

# when showing all solutions and animating the solution change.

# Point Type RED GREEN BLUE PATTERN

DEFAULT = 1.0, 1.0, 1.0, 0xffff

BP ALG = 1.0, 0.0, 0.0, 0xffff

LP ALG = 0.0, 1.0, 0.0, 0xffff

HB = 0.0, 0.0, 1.0, 0xffff

UZ4 = 1.0, 1.0, 0.0, 0xffff

UZ-4 = 0.5, 0.5, 0.0, 0xffff

LP DIF = 0.0, 0.0, 0.5, 0xffff

BP DIF = 0.0, 0.5, 0.5, 0xffff

PD = 1.0, 0.0, 1.0, 0xffff

TR = 0.0, 1.0, 1.0, 0xffff
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EP = 0.3, 0.0, 0.3, 0xffff

MX = 0.6, 0.0, 0.6, 0xffff

OTHERS = 1.0, 1.0, 1.0, 0xffff

# Initialize the line pattern for showing stability:

UNSTABLE LINE PATTERN = 0xffff

STABLE LINE PATTERN = 0xffff

# Initialize the default options:

Draw Reference Plane = No

Draw Reference Sphere = No

Orbit Animation = No

Satellite Animation = No

Draw Primaries = No

Draw Libration Points = No

Normalize Data = No

Draw Labels = No

Show Label Numbers = No

Draw Background = No

Draw Legend = No

# Initialize the default coordinate axes:

# 0 --- None,

# 1 --- at origin

# 2 --- at left and behind

# 3 --- at left and ahead

# 4 --- always at origin

Coordinate Type = 3

# Draw Scale on the Aexs

Draw Scale = Yes

# Initialize the default graph type:

# 0 --- Solution (fort.8)

# 1 --- Bifurcation (fort.7)

Graph Type = 0

# Initialize the default graph style:

# 0 --- LINES,

# 1 --- TUBES,

# 2 --- SURFACE

Graph Style = 0

# Set the window width and height:

Window Width = 1000
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Window Height = 1000

# Set X, Y, Z axes for the solution diagram:

# 0 is Time for X,Y,Z.

X Axis Solution = 1

Y Axis Solution = 2

Z Axis Solution = 3

# Set X, Y, Z axes for the bifurcation diagram:

X Axis Bifurcation = 4

Y Axis Bifurcation = 5

Z Axis Bifurcation = 6

#Labeled solutions:

Labels = 0

# Set coloring method:

# -6 --- STABILITY

# -5 --- POINT

# -4 --- BRANCH

# -3 --- TYPE

# -2 --- LABEL

# -1 --- COMPONENT

# Otherwise, according to the data in the ith column of the solution file.

# It can only be set to an integer value.

#Coloring Method = -3

# For the solution diagram:

Coloring Method Solution = -3

# For the bifurcation diagram:

Coloring Method Bifurcation = -3

Number of Period Animated = 1

# Line Width Scaler adjusts the thickness of curves:

Line Width Scaler = 1.0

# The AniLine Thickness Scaler sets the thickness of animated solution curves:

AniLine Thickness Scaler = 3.0

# Background color:

Background Color = 0.0, 0.0, 0.0

# Background transparency:

Background Transparency = 0.0

# Set the radius of the spheres used for labels:
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# The normal size is 1.0.

# For smaller radius, use 0.xxx

# For bigger radius, use X.XXX

Label Sphere Radius = 1.0

# Disk Rotation

Disk Rotation = 1.0, 0.0, 0.0, 1.570796

# Disk Position

Disk Position = 0.0, 0.0, 0.0

# Disk Radius

Disk Radius = 1.0

# Disk Height

Disk Height = 0.001

# Disk Transparency [0, 1]

Disk Transparency = 0.7

# Read Disk From File

Disk From File = No

# Sphere Position

Sphere Position = 0.0, 0.0, 0.0

# Sphere Radius

Sphere Radius = 1.0

# Sphere Transparency [0, 1]

Sphere Transparency = 0.7

# Read Sphere From File

Sphere From File = No

# Axes color:

X Axis Color = 1.0, 0.0, 0.0

Y Axis Color = 0.0, 1.0, 0.0

Z Axis Color = 0.0, 0.0, 1.0

# Color of the satellite, large primary, and small primary in animation:

satellite Color = 1.0, 0.0, 0.0

large primary Color = 0.0, 1.0, 0.0

large primary tail Color = 0.0, 1.0, 1.0

small primary Color = 0.0, 0.0, 1.0
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small primary tail Color = 0.5, 0.5, 0.0

# Surface color:

Surface Color = 0.0, 1.0, 0.0

# Stable solution color:

Stable Solution Color = 0.0, 0.0, 1.0

# Stable solution color:

Unstable Solution Color = 1.0, 0.0, 0.0

# Set the radius of the satellite, large primary, and small primary:

# The normal size is 1.0.

# For smaller radius, use 0.xxx

# For bigger radius, use X.XXX

Satellite Radius = 1.0

Large Primary Radius = 1.0

Small Primary Radius = 1.0

Libration Point Size = 1.0

# Set the initial, maximum and minimum satellite animation speed:

Sat Animation Speed = 100

Sat Max Animation Speed = 100

Sat Min Animation Speed = 0

# Set the initial, maximum and minimum orbit-change animation speed:

Orbit Animation Speed = 50

Orbit Max Animation Speed = 100

Orbit Min Animation Speed = 0

# Set the active AUTO parameter indices:

parameter ID = 10

# Choose 3D or 2D graph:

#3D = Yes

# Choose 3D or 2D graph for the bifurcation diagram:

3DBif = Yes

# Choose 3D or 2D graph for the solution diagram:

3DSol = Yes
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3 Example

In this example, we want to view a CR3BP data set. We want the diagram
to show the “x” component on the X-axis, “y” component on the Y-axis, and
“z” component on the Z-axis for the solution diagram. In the CR3BP, we use
the parameters “1 2 3 10 21 22 23” in the AUTO calculations, and we also
want to be able to use these to color the diagram, so we set the “parameter
indices”.

Other preferences include

• The diagram is drawn using Tubes.

• Coordinate axes are not drawn.

• No animation.

• Reference plane, libration points, and primaries are drawn.

• All labels are shown.

• Data is not normalized.

The settings are the settings in the resource file are then as follows:

# Initialize the default options

Draw Reference Plane = Yes

Orbit Animation = No

Satellite Animation = No

Draw Primaries = Yes

Draw Libration Points = Yes

Normalize Data = No

Draw Background = No

# Initialize the default graph type

# 0 --- Solution(fort.8) 1 --- Bifurcation(fort.7)

Graph Type = 0

# initialize the default graph style

# 0 --- LINES, 1 --- TUBES, 2 ---- SURFACE 3--- nurbs curve

graph Style = 1

# set X, Y, Z, and Label

# 0 is Time for X,Y,Z. 0 is "All" for Label
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Solution X Axis = 1

Solution Y Axis = 2

Solution Z Axis = 3

Labels = 0

#set the parameter indices

parameter ID = 1, 2, 3, 10, 15, 21, 22, 23

Based on the above settings, the solution diagram for the CR3BP family
 L1 for µ = 0.01215 appears in Figure 11.

Figure 11: Example
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